CONFIGURACIÓN DE QUAGGA EN LINUX

Quagga es un servicio de linux que nos permite enrutar redes usando a nuestro linux como un router, para ello seguimos los siguientes pasos:

1. para instalar quagga digitamos:

#apt-get install quagga

2. configuramos los demonios para que active zebra y ripd con el siguente comando:
    
#nano /etc/quagga/daemons  y cambiamos a yes:

zebra=yes
bgpd=no
ospfd=no
ospf6d=no
ripd=yes
ripngd=no


3. Después hay que entrar a la ruta cd /usr/share/doc/quagga/examples/ y copiar los archivos zebra y ripd a la ruta /etc/quagga, quedaría así:

#cp /usr/share/doc/quagga/examples/zebra.conf.sample /etc/quagga/zebra.conf
#cp /usr/share/doc/quagga/examples/ripd.conf.sample /etc/quagga/ripd.conf


4. Reiniciamos el servicio de quagga:

#sudo /etc/init.d/quagga

5. Ahora podremos acceder por separado con una interfaz interactiva a cada uno de los demonios. Para acceder a Zebra (Password por defecto zebra):
#telnet localhost 2601 o zebra
Password: zebra

Router>enable
Router#conf t
Router(config)#interface eth0

Router(config-if)#ip address 200.100.100.1/24
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)# exit
Router# write
Configuration saved to /etc/quagga/router.conf

#telnet localhost 2602 o ripd
Password: zebra

ripd> enable
ripd# configure terminal
ripd(config)# router rip
ripd(config-router)# network 200.100.100.0/24
ripd(config-router)# network 192.168.1.0/24

ripd(config-router)# network 192.168.2.0/24
ripd(config-router)# network 192.168.3.0/24
ripd(config-router)# exit
ripd(config)# exit
ripd# write
Configuration saved to /etc/quagga/ripd.conf

6. Despues de configurar todo lo de quagga procedemos a configurar las tarjetas de red. Para eso editamos el archivo:

#nano /etc/network/interfaces

auto eth0
iface eth0 inet static
address 200.100.100.1
netmask 255.255.255.0
network 200.100.100.0
broadcast 200.100.100.255



auto eth1
iface eth1 inet static

auto eth1.101

iface eth1.101 inet static
address 192.168.1.1
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255

auto eth1.102
iface eth1.102 inet static
address 192.168.2.1
netmask 255.255.255.0
network 192.168.2.0
broadcast 192.168.2.255

auto eth1.103
iface eth1.103 inet static
address 192.168.3.1
netmask 255.255.255.0
network 192.168.3.0
broadcast 192.168.3.255

Luego le damos "control mas o" y enter y despues "control mas x" para salir.

7. despues de hacer estas configuraciones hay que restaurar el servicio de red con el siguiente comando:

#sudo /etc/init.d/networking restart

8. despues hay que activar el enrrutamiento en GNU/Linux con el siguiente comando:

#echo "1" > /proc/sys/net/ipv4/ip_forward

y para que no se borre despues de reiniciar el sistema utilizamos la siguiente linea:


#echo "net.ipv4.ip_forward = 1" >> /etc/sysctl.conf


1 comentario:

  1. Hola. Excelente tu blog.
    Estoy intetando establecer una topología de tres redes, dos ipv6 con una red ipv4 que las separa. Necesito configurar un metodo de tunelización usando Quagga o algo parecido. Tendrías aguna idea de como realizar la configuración? Estoy usando maquinas virtuales con Debian para simular los enrutadores

    ResponderEliminar